Software improvements

Posted By puckkk Saturday, April 14, 2012
Add to Favorites1
Author Message
puckkk
 Posted Saturday, April 14, 2012
Supreme Being

Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)

Group: Forum Members
Last Active: Friday, April 12, 2013
Posts: 15, Visits: 114
Hello. I'd like to share with programmers two ideas I think could be nice improvements for the platform. In my opinion, they could be called simple bugs too Smile: they are there for a long long time...:

1) Text added to the chart is never saved: other object (trend lines fibonacci etc.) are always saved. On the contrary all written texts, when you close the platform and then reopen it, are deleted...
2) Vertical autoscale on/off status and crosshair status are not saved too. I personally always use autoscale off and crosshair on, but i need to reset it for every charts every time I open the platform because these settings are not saved... I think they are common settings and should be saved like other ones.

Have a nice day.
Admin
 Posted Friday, April 20, 2012
Administrator

Administrator - (123,783 reputation)

Group: Administrators
Last Active: Friday, June 02, 2017
Posts: 548, Visits: 3,295
Dear puckkk,
as for the first paragraph about saving text on charts - problem has been fixed and the fixed version of application will be released soon,
as for the second paragraph about autoscale and crosshair – the information is forwarded to our specialists.
Thank you for advice!


Best regards

-ACTFX© Forum Administrator
puckkk
 Posted Friday, April 20, 2012
Supreme Being

Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)

Group: Forum Members
Last Active: Friday, April 12, 2013
Posts: 15, Visits: 114
Admin (4/20/2012)
Dear puckkk,
as for the first paragraph about saving text on charts - problem has been fixed and the fixed version of application will be released soon

Great Smile.


as for the second paragraph about autoscale and crosshair – the information is forwarded to our specialists.
Thank you for advice!

Great, again Smile. Hope to see that improved too Smile.
puckkk
 Posted Saturday, June 16, 2012
Supreme Being

Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)

Group: Forum Members
Last Active: Friday, April 12, 2013
Posts: 15, Visits: 114
Hello. Sorry for bothering but: with new version text is not yet working. If I place text on charts, then close the app and restart, the chart doen't load throwing "range check error". Here the stack call:EXCEPTION
ERangeError in TChart
CODE

MESSAGE
Range check error
DETAILS

CALL STACK
fx_client.exe=>TeEngine.pas=>TChartAxis.YPosValueCheck=>4450
fx_client.exe=>TeEngine.pas=>TChartSeries.CalcYPosValue=>11132
fx_client.exe=>FxChartDrawTool.pas=>TChartText.Draw=>3188
fx_client.exe=>TeEngine.pas=>DoDraw=>13503
fx_client.exe=>FxChartDrawTool.pas=>TFxDrawTool.ChartEvent=>524
fx_client.exe=>TeEngine.pas=>TCustomAxisPanel.BroadcastToolEvent=>12975
fx_client.exe=>TeEngine.pas=>TCustomAxisPanel.BroadcastToolEvent=>12972
fx_client.exe=>TeEngine.pas=>TCustomAxisPanel.InternalDraw=>13253
fx_client.exe=>TeeProcs.pas=>TCustomTeePanel.Draw=>1597
fx_client.exe=>TeeProcs.pas=>TCustomTeePanel.Draw=>1507
fx_client.exe=>TeeProcs.pas=>TCustomTeePanel.Draw=>1506
fx_client.exe=>TeeProcs.pas=>TCustomTeePanel.Paint=>1634
fx_client.exe=>TeeProcs.pas=>TCustomTeePanelExtended.WMPaint=>3141
fx_client.exe=>cxContainer.pas=>ApplicationCallWndProcHookProc=>6194
USER32.dll=>=>GetRawInputDeviceInfoW=>0
fx_client.exe=>dxSkinsForm.pas=>TdxSkinWinController.WndProc=>1300
USER32.dll=>=>CallNextHookEx=>0
fx_client.exe=>dxSkinsForm.pas=>dxSkinsWndProcHook=>4342
USER32.dll=>=>UpdateWindow=>0
fx_client.exe=>RateLine.pas=>TRateLine.NewRate=>171
fx_client.exe=>RateLine.pas=>TRateLine.NewRate=>166
fx_client.exe=>ChartWindowBase.pas=>TForm_Chart.OnEndOfDataRequest=>5788
fx_client.exe=>ChartWindowBase.pas=>TForm_Chart.OnEndOfDataRequest=>5740
fx_client.exe=>ChartWindowBase.pas=>TGetChartsBackWork.ProcessData=>796
USER32.dll=>=>DispatchMessageW=>0
USER32.dll=>=>DispatchMessageW=>0
fx_client.exe=>Fx_Client.dpr=>=>452

WINDOWS VERSION
6.1.7600 Service Pack 1
APPLICATION INFO
fx_client.exe 4.5.233.6/4.5.233
http://real4.sysfx.com:8035/xml/; eforex35; TRADER: puckkk
RAISE TIME
2012-06-16 21:13:28
Server Time: 15:13:28
Saturday, June 16, 2012 by puckkk
Admin
 Posted Tuesday, June 19, 2012
Administrator

Administrator - (123,783 reputation)

Group: Administrators
Last Active: Friday, June 02, 2017
Posts: 548, Visits: 3,295
Dear puckkk,it is difficult to reproduce the problem in current version of ActTrader, so could you attach here the "Fx_Client.puckkk.eforex35.ini" file which is used for your entering the platform?
The file is located in the root folder of ActTrader.


This .ini file should contain all information of your user interface settings to be sure, please, open the platform, and add the text on a chart - do it at the same way as you did to reproduce the problem, but copy the .ini file before next launch of the application.



Best regards

-ACTFX© Forum Administrator
Tuesday, July 03, 2012 by Admin
puckkk
 Posted Tuesday, June 19, 2012
Supreme Being

Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)

Group: Forum Members
Last Active: Friday, April 12, 2013
Posts: 15, Visits: 114
Installed a fresh new copy of the platform in a new dir. Just create a standard new chart and put in it a text label (with text = "Abc"). Same problem occurred. Attached is the ini file.
 Fx_Client.puckkk.eforex35.zip (5 views, 9.27 KB)
Admin
 Posted Tuesday, July 03, 2012
Administrator

Administrator - (123,783 reputation)

Group: Administrators
Last Active: Friday, June 02, 2017
Posts: 548, Visits: 3,295
Dear puckkk,we have tried to reproduce described error, but unfortunately we couldn't reproduce it even with your .ini file on the machine with the same OS.
There were checked a lot of scenarios, but exception did not appear and the text was displayed correctly during any testing.
In such case it's impossible to make any fixes and check them. Sorry.

Best regards

-ACTFX© Forum Administrator
Tuesday, July 03, 2012 by Admin
puckkk
 Posted Thursday, July 05, 2012
Supreme Being

Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)

Group: Forum Members
Last Active: Friday, April 12, 2013
Posts: 15, Visits: 114
Mmm... odd. I have the same issue on 3 different pc. (2 XP and 1 win7 64 buts). Today after reading post I tried a fresh new install on my remote server (running windows server 2003). Text label are working well. Really cannot understand.

I just noticed that in the install directory of windows server 2003 is not present the gdiplus.dll. In the installation directory of the other psc the gdiplus.dll is present. Tried to remove them. But still the same. If I change the y_value of the text label of the .ini file the error is no more popping up, but the label isn't showing on the chart...


I'll try tomorrow on another pc running xp... but I'm really out of ideas. But i really want text label working. Am I really the only one with this problem Smile!?
Admin
 Posted Friday, July 06, 2012
Administrator

Administrator - (123,783 reputation)

Group: Administrators
Last Active: Friday, June 02, 2017
Posts: 548, Visits: 3,295
Thank you puckkk,this information was helpful - now the possible reasons of a problem are more clear.
Our specialists are investigating the situation.
Tell us, please, what is localization of your Windows?


Best regards

-ACTFX© Forum Administrator
puckkk
 Posted Friday, July 06, 2012
Supreme Being

Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)Supreme Being - (4,485 reputation)

Group: Forum Members
Last Active: Friday, April 12, 2013
Posts: 15, Visits: 114

Tell us, please, what is localization of your Windows?


Exclamation Markw00tYouuu goooot it BigGrin

My remote server is using localization United States_English. Changed to Italian_Italy (all other PCs that had problems are running IT-it, because I'm from Italy) and error comes out on the remote server too.


Changed other PCs to US_en: all PCs are now running ok with all the labels showing right. Just a "localization issue" Smile.
I'm now working with US_en on my PC... waiting for the fix to get back to my usual IT_it.
Great. Great. Great. I now have the text labels Smile.

Similar Topics

Expand / Collapse

Reading This Topic

Expand / Collapse

Back To Top